SFOTT | YOSEMITE : success

Thanks to macrumors great people, I too, succeeded to install YOSEMITE (on my MacMini2,1)
I do not have anymore MacPro1,1 at hand to test on it.
But if a MacMini2,1 takes it, no worries Macpro1,1 & 2,1 will do has others machines.
take a look at the thread http://forums.macrumors.com/showthread.php?t=1740775

So far Tiamo’s boot.efi is not compatible with YOSEMITE as is,
but pikerAlpha has worked on it and made his own branch.

It’s now referred as Pikeralpha boot.efi branch  (based on Tiamo’s boot.efi work).
Hennesie2000 has compiled it and made it available on the post.
Those code killers (at least) and all others members on this thread are now to be rewarded.

YOSEMITE_GMC_screenShots_MacMini

Concerning SFOTT script : 

Slight changes have to be made to the script to get it working.
I’m confident to say that based on all the work done here  SFOTT should be able to build YOSEMITE installer as it did for Mavericks.
I’ve already worked on Most of the Code, but I still have to include mandatory new steps. Follow above Macrumors thread if you want to know more.

I’ll do my best to release a new SFOTT for YOSEMITE Beta and DP-GMC version this upcoming week-end.
I actually used for a test the GMC1 released few days ago.
I’ll test the public Beta, too and it already included as an option on the SFOTT script.

And the Recovery Partition has been created. – but not yet tested…

Stay tuned

YOSEMITE helpfull urls:

http://forums.macrumors.com/showthread.php?t=1740775 Synthesis for all good infos and some boot.efi release
http://forums.macrumors.com/showthread.php?t=1761432
http://pikeralpha.wordpress.com  pikeralpha’s blog.
https://github.com/Piker-Alpha/macosxbootloader repo for the new branch of Tiamo’s boot.efi compatible for Yosemite from pikeralpha

EDIT 20141008 :

I also did the update of the GMC 2 released yesterday. directly from the AppStore.
mitigated result.

Boot time is longer, many errors show up and loging time is really long and bugged.
Then once display sleep comes up, and I wake it up, then it’s ok.
For me it is clearly due to the graphics.
Remember : 

– Installing Mavericks and now Yosemite is one thing.

– Getting a usable System is another thing.

Now this said,  MacPro and Xserve 1,1&2,1  should go smoothly with adapted video card.

If you want to test the beta of Sfott for Yosemite go here on page SFOTT | YOSEMITE beta release

Read carefully.

Olivier
About

Product and graphic designer turned to be a Mac SysAdmin.

Posted in sfott Tagged with: , , , , , , , , , , , , , ,
44 comments on “SFOTT | YOSEMITE : success
  1. Рустам says:

    Hi, Oem.
    So much waiting for your release for 10.10.
    Thanks for your work!

  2. Tom says:

    Thanks for the great work.

    Can you make it possible to boot with the Apple logo instead of the verbose mode?

    • oem oem says:

      Hi Tom,

      Well :
      1°) nope. I did not compile myself the boot.efi from Pikes.

      This is in his hands. for now my guess is that until officially released it will stay verbose.
      Maybe then a graphic boot.efi will show up and I think Pikeralpha is working on it.

      2°) I eventually may take a look at compiling this boot.efi stuff, but that would mean working on W$ on a VM and having some coding utilities on Windows…
      so maybe for my personnal knowledge, but I’ll rely on Pikeralpha, Hennessie2000 until then.

      Be sure that I’ll adapt the SFOTT script when a secondary graphic Pikeralpha’s branch of Tiamo boot.efi will be available. :)

  3. manouille says:

    Superbe travail , vivement la version 10.10 pour mac pro 2.1

    cordialement

    Manouille

    • oem oem says:

      Merci du compliment :)

      je travaille hardament sur Yosemite.

      Code quasi pret mais la Recovery me pose des soucis car là elle est faite directement mais je n’arrive pas à booter dessus, alors que c’est l’image utilisée pour faire la clé USB qui elle boot sans probleme… bizarre.

  4. b33 says:

    Hey oem, thanks for your work on this! I am excited for the final release :)

  5. M. P. says:

    I was also succesfully in Running Yosemite up to 14A388a on my macmini 2.1; but without Sound (only line in and line out).
    I installed the System on my Hackintosh (macpro 3.1 with clover) to a Partition of my “Special” Mac Mini’s HD.
    THEN I FOUD A BOOT.EFI which was able to boot the yosemite from it’s hd in the mini.
    Must be pikerAlpha’s boot.efi

    But now i am not able to get sound and grafics. No kext loaded for grafics !

    still waiting for these kexts.

    P.S. Running Mountain lion at the moment on the Macmini 2,1

    • oem oem says:

      My MacMini2,1 under YOSEMITE is not really usable if I can say.

      the login window is completely bugged and I sometimes have to wait for a debug step to occurs to be able to reach the Desktop…

      I accept that because I just want to test SFOTT, as I do no have anymore the MacPro1,1 now.

      I also noticed that in 10.9 I had 64 Mb of RAM and then after 10.9.1 and more 7MB !….
      I may search on that someday.

      • M. P. says:

        I am not a professional in understanding what i am doing to run os x aon my mac but today i found these commands in the net.

        sudo nvram boot-args=”kext-dev-mode=1″

        sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

        Now the grafics are fully supported in Yosemite. Mavericks Tester says >= 256 Mb

        For wat i am using the mac mini, it is fully Ok

        Sound is now the last thing that is not working.

        There are no “geräte” im “systembericht” Audio while all in intelhighdefinitionaudio is Totally Ok.

        But without “Geräte” there is no sound device in “Systemeinstellungen”

        But i think i can also fix this when i can find a solution for this in the net.

        M.P.

  6. disco says:

    If you need a tester for a MacPro1,1 I’m happy to help. My Pro is fully loaded with HDDs and I have partitions reserved for testing purposes.
    Kepp up your great work!
    Regards, d.

    • oem oem says:

      Hello Disco,

      Noted,
      I’ll make some last test again tonight and post it.
      Was trying to get Recovery working but until now it does not work. – but I’m not alone in that case. I postponed Sfott release just because of that. It should be soon available.

  7. Ken Spelke says:

    Can the Yosemite upgrade be run from the App Store onto a Mac Pro 1,1 currently successfully running Mavericks 10.9.5 (thanks to your great work!!!) without the need for additional patches and steps as were required for the upgrade from Lion to Mavericks?

    Thanks for any information / guidance you are able to provide.

    All the best,

    Ken

    • oem oem says:

      Hi Ken,

      If you mean can I upgrade from Appstore without creating a Key again. NO.
      you’ll have to creat ea Key, then update your system. I’ve not tried that.

      BE SURE TO HAVE A VALID BOOTABLE BACKUP/CLONE of you running system if you intend to do so.

      • Ken Spelke says:

        Thanks so much for this timely and helpful information – I do appreciate it. I guess I’ll need to try to download the installer from the App Store to see if that part works… with Mavericks, as we all recall, Apple wouldn’t permit the installer to install on “incompatible” hardware systems.

        • oem oem says:

          Ken,

          you have to ask a friend or use Mavericks Download Enabler from Rastafabi on MacRumors

          • Ken Spelke says:

            Yup, will do. At least I have the good thumb drive I provided to my friend the last time when she downloaded the Mavericks installer file for me. Now, that’s what I call “recycling!” Thanks again for all of your good work for all of us.

  8. I have the final release of Yosemite now working on my Mac Pro 1,1. 2.66 GHZ with 16 gigs of ram. Everything is working well but Bluetooth was having issues with trackpad and wireless mouse. Hooked up older mac mouse and everything is great. Still not able to use iMessage or FaceTime, would really like to see that fixed. But other than that everything is working great. Ready for another year out of this old beast!

    • oem oem says:

      Hello Michael,

      Good you installed fine.
      For iMessage or FaceTime almost sure it is because of the Recovery Issue….

  9. Chase says:

    I tried this on a macbook 4,1, but on the part where it’s supposed to copy the yosemite kernel, it comes up with “Yosemite kernel tmp missing.”

    I’m using the official Yosemite installer.

    • oem oem says:

      Hello Chase,

      Have run runned the Sfott installer ? it should copy the kernel in the tmp directory here :
      /private/tmp/SixtyFourOnThirtyTwo/YOSkernel.
      If you don’t have the folder and it’s content it will fail. let me know.

      • Chase says:

        Thanks for the reply oem

        By Sfott installer I assume you mean the .pkg? I did run the .pkg file and everything seemed like it was installed correctly.

        The SixtyFourOnThirtyTwo folder did show up in the tmp directory, but the YOSkernel folder was nowhere to be found.

        I ran the autorun process again to see if it would show up, but sure enough, when the time came for it to copy the kernel, the YOSkernel folder still wasn’t there.

        Thanks for the help

        • oem oem says:

          Weird,

          I have to check this out, I’m (almost) sure the YOSkernel is there…
          I’ll install the Beta on my laptop to recheck this out.

  10. smate333 says:

    Clean Yosemite install on MacPro 1.1 with 5570 mac graphics and 16 gigs of ram, no problems, on sata 3, but will clone to ssd after data migration. Upgrade from Mavericks didn’t work, got stuck on progress bar, had to do clean. Also iMessage and FaceTime won’t let sign in, but I know there is a fix, I forgot what it was. Performance is awesome otherwise, not sure why Apple decided to drop us 32ers. Thank you so much for this opportunity!!!

    Merci beaucoup monsieur!!!

    • oem oem says:

      Bonjour Smate333,

      merci à vous ! :)

      Enjoy.

      N.B. : For iMessage and Facetime I think this relies on the recovery and so far we’ve not been able to get it booting. I have to go and check on MacRumors thread…

  11. M. P. says:

    Removed a Sounkext while Testing Trying to get sound working. I put this kext back to extensions.
    then i put this command

    sudo kextcache -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

    another time into terminal

    and after a restart sound works too.

    must be a problem with unsigned kexts in yosemite. normlally these kexts are not working.

    M.P.

    • oem oem says:

      Hello M.P.

      Good infos, I’ve too read and I’ll see how I could add those to help or just as an option but would need to be on the booted system or choose the right one….

      I mark this as TIP so I lately add it in troubleshooting Yosemite.

      BTW what hardware are you running ? Macmini ?

      • M. P. says:

        My Macmini is a 2,1 Model with a 2 GHz Core 2 Duo CPU and 4 Gig RAM 3 Gig usable because of the 32 bit limit.
        A 500 Gig HD with 5 partions and 10.6 10.9 and 10.10 on a partition. The Kexts for graphics and sound are the ones from 10.9 (i think) which was installed with sfott on a Macbook 2,1 with 3 Gig of memory. Then i cloned the Hd and fit it into a macmini 1,1. Now i was able to find a macmini 2,1 from which i only used the mobo and another macmini 1,1 case without mobo. The macmini has no HD and Optical drive in its case. I bought 2 Calbes and a ATA to SATA adapter and put the adapter and the cables into an external box for 2 5,25″ cases.
        In this box i put two “wechselrahmen” frames were you can swap hd’s. So it it very easy to change an hd in about 1 minute.

        hope this helps.

        M. P.

  12. foudeapple says:

    Hello à tout !

    effectué avec SFOTT beta Yosemite avec Yosemite officiel (AppleStore)

    Fonctionne l’installation de Yosemite officiel sur macpro1,1 et upgradé firmware 2,1 a partir de 10.7.5 ->aucun problème. aucun bug constaté pour l’instant.

    Ne marche pas sur le système avec appleRAID 2.0 ! l’icône de l’interrogation apparait !! peut être l’absence dans le package de RAID ? -> obligé d’installer dans un seul disque dur et ça marche !

    L’installation du package Yosemite sur la clé USB ou autre ne fonctionne pas à partir d’un partition de 10.9.x dans Macpro1,1 a cause de l’inutilité de patcher le boofi EFI64 déjà existant dans la clé USB ! il faut quand même forcer le patch ! et vous ?

    La mise à jour de Yosemite sur une partition déjà existante est déconseillé !!

    Le clean install est fortement conseillé. Attention la migration fonctionne uniquement sur des partitions de démarrage !! faites vos sauvegardes !

  13. Roman says:

    I found a little trick for video on Mac mini 2.1.
    Use Quartz Debug app, in Beam Sync click “disable” and video will work fast and good, except using video editing apps like final cut pro, it will not work.
    Cheers.

  14. jl123 says:

    Successfully installed beta with Yosemite and OS X Server application.

  15. manouille says:

    Sucess :p

    Mac Pro 1,1 –> 2,1
    16 gigas RAM, Ati 4870 1go RaM ,
    4 HDD 250 gigas + 1 SSHD 1 To ( System )
    Snow Leopard > Maverick (( w/ SFOTT ) > Yosemite ( SFOTT Beta )

    I message not working … :(

    How Create an HD RECOVERY

    • oem oem says:

      Hi,

      for iMessage it needs Recovery. recovery is not working for now. but it’s been some time I’ve not looked at the dev of PikerAlpha boot.efi. SO maybe it is ok now.
      I’ll take a look this week-end at the main thread on macrumors.

      thx to report working hardware.
      cheers

  16. J S says:

    Up and running with Yosemite, downloaded on a MacBook Pro and installed on a 2006 MacPro 1, 1 turned 2,1 with dual xeon 3.0 ghz quad-cores, 3GB Sapphire HD 7950, 16 GB ram and Samsung EVO 840 128GB SSD (boots in like 1 minute)! Keeping my Mavericks install intact on other drive as I couldn’t get iMessage and FaceTime working. I called apple with serial and they reset, but still didn’t get it. No sweat though, I still appreciate what you’ve done and am grateful for what it has allowed me to do . I have two kids and a new job too. ….took me 3 weeks to build my SOFTT key. I thought I was gonna explode!!! lol. Thanks for your work. Keep loving those kids, … they’re only little for so long.

    • oem oem says:

      Hello JS,

      for iMessage it is due to recovery trouble. as I just said on another reply; I have to go on the main thread to see if things have evolved with boot.efi and Recovery.
      cheers

  17. Ludovit Tatos says:

    Thanks OEM,
    Just installed “Yosemite” official release on
    Mac Pro 1.1 2006, 12GB RAM, ATI Radeon HD 5770 1024 MB.
    Everything works like a champ. Install went without a single issue…just perfect.
    thanks again OEM

    • oem oem says:

      Enjoy.

      • Hey Thanks OEM,

        I am running Yosemite on my Macbook 2,1 (Mid 2007) and it is working flawlessly, no lag, no glitches, runs even my Adobe Lightroom 6 using RAW images with ease.

        Apple wrote off that older model and SFOTT has given my old macbook a new life, why buy a new one this one seems to be working just fine! I wonder if I could pouch the boundaries and maybe get El Capitan to run on it? haha

        THANK YOU!

  18. Kevin says:

    Installed Yosemite official release on my MacPro 1,1
    – 2 x 2 GHz Dual-Core Intel Xeon
    – ATI Radeon HD 5770 1024 MB
    – 16 GB 667 MHz DDR2 FB-DIMM

    Works perfect! Thank you very much.

    QUESTION: Installed Yosemite on a WD Blue Drive 750 GB which used up 50 GB.
    I just bought a Crucial MX100 128GB SATA 2.5″ 7mm (with 9.5mm adapter) Internal Solid State Drive CT128MX100SSD1 with an Icy Dock EZConvert 2.5-Inch to 3.5-Inch SATA SSD / Hard Drive Converter.

    How can I clone the Yosemite-installed WD HDD onto my new CRUCIAL SSD (128 GB) so I can be running Yosemite on an SSD?

    Thanks!

    • Kevin says:

      Was easy. I used Carbon Copy Cloner to clone to the new SSD, booted into it, and it’s running lightning fast.

      Great work to everyone who worked on this!!!

  19. Vladi says:

    I have a problem. The Yosemite runs on my Mac Pro 1.1 on HDD. I would like to clone my HDD to SSD. But after cloning the SSD image doesn’t start. After login mask the boot is frozen. I tried to replace the efi files. But it doesn’t help. What do I wrongly?

  20. Vladi says:

    Sorry, already fixed the problem. The cloning program (Carbon) has overwritten the System/Library/CoreServices/PlatformSupport.plist file. My platform disappeared from the list. No idea, why. But now everything seems to be fine.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>