Install ESXi 5.5 on MacPro3,1 with dead onboard Ethernet and a Marvel 88E8053 PCI card.

So this is the follow up of this post : http://oemden.com/?p=1222
My MacPro3,1 is a recovered MacPro that had been thunderstruck – yeah you read well and the motherboard NIC chips have died ( the Graphic Card has died too but not for the same reason).
I have a PCI gigabit NIC from Marvell (88E8053) and all is fine except one thing : I can’t authenticate to the App Store as no built-in NIC card is detected, and even if built-in Wifi is there, only the MAC address of the built-in NIC will make you authenticate with App Store (except for the macBookAir).
I’ve tried Hackintosh tricks but has it is a PCI-E card and not motherboard NIC I did not succeeded.
This MacPro is my Dev/stage Server , it runs well and I can update it, so I did not wasted time on this.

Enough writing :  let’s install ESXi 5.5

I first downloaded the 5.5 .iso from VMWare and followed the same steps as for the 5.1 using unetbootin to Prepare the key, and then Boot the MacPro holding the alt-option key and choose the EFI USB showing up.

but I’ve got an error…again

To make things short, it now tells me that I don’t have NIC cards. WTF No Network ?
Ok some search again and we found that VMWare removed some drivers from the ESXi5.5 release.

It only Officially support Intel NIC. No more Marvell nor Realtek.
So Drivers included in the ESXi5.1 that permitted me to get Network, go on and install ESXi 5.1 with success are gone.

So, we have to create a custom .iso

Create a custom ISO with PowerCLI

Here you need a windows Box.

I have a W7 Parallels that I’ll use.
I simply followed the very well explained procedure found here

Download PowerCLI from VMWare here

Launch PowerCLI (with an admin account)

  • let’s add ImageBuilder snapin – if you did already you’ll have an error, don’t worry and follow the steps.
Set-ExecutionPolicy RemoteSigned
  • add the ImageBuilder snapin.
Add-PSSnapin VMware.ImageBuilder
  • Connects to the software depot
Add-EsxSoftwareDepot https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
  • Lists only 5.5 ESXi imageProfiles
cd Z:\
Get-EsxImageProfile ESXI-5.5*

#This will narrow the list.. I’ve tried to get the latest “standard” ESXi 5.5 image.

  • Choosed the “ESXi-5.5.0-20140704001-standard” iso and clone it (to add the missing drivers).
New-EsxImageProfile -CloneProfile "ESXi-5.5.0-20140704001-standard" -name "ESXi-5.5.0-20140704001-Whitebox" -vendor "withNICs"

ESXi5.5_MacPRO3,1_PowerCLI-1

  • Add the Marvell adapters (the only I need).
Add-EsxSoftwarePackage -ImageProfile "ESXi-5.5.0-20140704001-Whitebox" -SoftwarePackage "net-sky2"

 

Add-EsxSoftwarePackage -ImageProfile "ESXi-5.5.0-20140704001-Whitebox" -SoftwarePackage "net-s2io"
  • We can create our custom .iso. Be patient it can take some times, depending on your hardware.
Export-ESXImageProfile -ImageProfile "ESXi-5.5.0-20140704001-Whitebox" -ExportToISO -filepath Z:\ESXi-5.5.0-20140704001-Whitebox.iso

Now, we have an fresh ESXi-5.5.0-20140704001-Whitebox.iso.

ESXi5.5_MacPRO3,1_PowerCLI-2

D) Prepare the key from the newly created .iso and install ESXi on the MacPro3,1

Take your USB stick, erase it with DiskUtility and just use unetbootin again.
Now we can start again from Step A) to create the ESXi Install USB stick.
And enjoy getting working NICs and be able to install ESXi on the MacPro3,1 with a custom Marvell PCI-E card NIC.

 E) Create your VM

Again here we need a Win Box.
Launch it and enjoy Netbooting; and installing a fresh OsX. You’ll also have to format your VM drive.

Note :
I had One trouble, as I had to declare the Netboot Image I wanted to use as the default one in Netboot settings.

I’ll dig on that later on as for Now The Macpro is still a Stage Running Server… and ESXi not primary launched System.

Next install OsX from Install Media and discover a bit more ESXi.

Olivier
About

Product and graphic designer turned to be a Mac SysAdmin.

Posted in Admin, Mac, tips tricks scripts, Windows Tagged with: , , , , ,
0 comments on “Install ESXi 5.5 on MacPro3,1 with dead onboard Ethernet and a Marvel 88E8053 PCI card.
1 Pings/Trackbacks for "Install ESXi 5.5 on MacPro3,1 with dead onboard Ethernet and a Marvel 88E8053 PCI card."
  1. […] was the culprit I don’t know. It did work like a charm when I installed ESXi see here and here on my […]

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>